内网IP段有哪些_为什么有些内网使用公网地址段

内网IP段有哪些_为什么有些内网使用公网地址段常见的内网IP段有:10.0.0.0/810.0.0.0-10.255.255.255172.16.0.0/12172.16.0.0-172.31.255.255192.168.0.0/16192.168.0.0-192.168.255.255以上三个网段分别属于A、B、C三类IP地址,来自《RFC1918》。但是根据《ReservedIPaddresses-Wikipedia,thefreeencyclopedia》及《RFC6890-Special

大家好,又见面了,我是你们的朋友全栈君。如果您正在找激活码,请点击查看最新教程,关注关注公众号 “全栈程序员社区” 获取激活教程,可能之前旧版本教程已经失效.最新Idea2022.1教程亲测有效,一键激活。

Jetbrains全系列IDE使用 1年只要46元 售后保障 童叟无欺

常见的内网IP段有:

10.0.0.0/8
10.0.0.0 – 10.255.255.255
172.16.0.0/12
172.16.0.0 – 172.31.255.255
192.168.0.0/16
192.168.0.0 – 192.168.255.255
以上三个网段分别属于A、B、C三类IP地址,来自 《RFC 1918》。

但是根据 《Reserved IP addresses – Wikipedia, the free encyclopedia》 及《RFC 6890 – Special-Purpose IP Address Registries》的描述,还有很多其它的内网IP段(包括IPv6),以及其它用途的保留IP地址。

其它IPv4内网段罗列如下:

0.0.0.0/8
0.0.0.0 – 0.255.255.255

用于当前网络内的广播消息。

100.64.0.0/10
100.64.0.0 – 100.127.255.255

由运营商使用的私网IP段,随着IPv4地址池的耗光,会有更多用户被分配到这个网段。

127.0.0.0/8
127.0.0.0 – 127.255.255.255

本机回环地址。

169.254.0.0/16
169.254.0.0 – 169.254.255.255

获取不到IP地址时使用,通常因为从DHCP服务器获取不到IP。

192.0.0.0/24
192.0.0.0 – 192.0.0.255

Used for the IANA IPv4 Special Purpose Address Registry as specified by RFC 5736

一般用户不可能被分配到这个IP段。

192.0.2.0/24
192.0.2.0 – 192.0.2.255

Assigned as “TEST-NET” in RFC 5737 for use solely in documentation and example source code and should not be used publicly.

一般用户不可能被分配到这个IP段。

198.18.0.0/15
198.18.0.0 – 198.19.255.255

用于测试两个独立子网的网间通信。

一般用户不可能被分配到这个IP段。

198.51.100.0/24
198.51.100.0 – 198.51.100.255

Assigned as “TEST-NET-2” in RFC 5737 for use solely in documentation and example source code and should not be used publicly.

一般用户不可能被分配到这个IP段。

203.0.113.0/24
203.0.113.0 – 203.0.113.255

Assigned as “TEST-NET-3” in RFC 5737 for use solely in documentation and example source code and should not be used publicly.

一般用户不可能被分配到这个IP段。

255.255.255.255/32
255.255.255.255

本网段的广播地址。

版权声明:本文内容由互联网用户自发贡献,该文观点仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 举报,一经查实,本站将立刻删除。

发布者:全栈程序员-站长,转载请注明出处:https://javaforall.net/193812.html原文链接:https://javaforall.net

赞 (0)
全栈程序员-站长的头像全栈程序员-站长


相关推荐

  • 利用STM32F103精确控制步进电机

    利用STM32F103精确控制步进电机**利用STM32F103控制步进电机精确角度转动**欢迎使用Markdown编辑器你好!这是你第一次使用Markdown编辑器所展示的欢迎页。如果你想学习如何使用Markdown编辑器,可以仔细阅读这篇文章,了解一下Markdown的基本语法知识。新的改变我们对Markdown编辑器进行了一些功能拓展与语法支持,除了标准的Markdown编辑器功能,我们增加了如下几点新功能,…

    2022年6月1日
  • 史上最强 Java 学习路线图!

    网上看到一首诗:“代码尽头谁为峰,一见秃头道成空。编程修真路破折,一步一劫渡飞升。”感觉还挺有意境的。第一部分:Java基础篇这个阶段就是编程入门,掌握Java这门编程语言的基本语法,为后面的修行之路打好基础。包括的知识点有:环境搭建——IntellijIDEA一站式搞定Java基础语法面向对象——封装、继承、多态数组字符串集合框架IO反射注解网络编程并发编程这方面的资源我给大家梳理下:1)针对IntellijIDEA,GitHub上有一份简体中文版教

    2022年4月11日
  • html网站怎么注入_跨站脚本攻击原理

    html网站怎么注入_跨站脚本攻击原理跨站脚本攻击(XSS)是一种客户端代码注入攻击。攻击者通过在合法的网页中注入恶意代码,达到在受害者的浏览器中执行恶意代码的目的。当受害者访问执行恶意代码的网页时,攻击就开始了。这些网页成为了将恶意代码发送到用户浏览器的工具。通常受到跨站脚本攻击的网页包括论坛、留言板以及可以评论的网页。如果网页将用户的原始输入作为网页内容,那么它很容易受到XSS攻击,因为这类用户输入一定会被受害者的浏览器解析。…

    2022年10月29日
  • SpringBoot 启动报 No bean named ‘org.springframework.context.annotation.ConfigurationClassPostProcessor.importRegistry’ available 异常

    SpringBoot 启动报 No bean named ‘org.springframework.context.annotation.ConfigurationClassPostProcessor.importRegistry’ available 异常

    2020年11月19日
  • mysql months_between_months_between()用法「建议收藏」

    mysql months_between_months_between()用法「建议收藏」orcl中months_between()函数用法如下:格式:即MONTHS_BETWEEN(日期1,日期2)例如:selectmonths_between(to_date(‘2018-10-9′,’yyyy-mm-dd’),to_date(‘2017-10-09′,’yyyy-mm-dd’))mfromdual;注:M:月selectmonths_between(to_date(’20…

    2022年7月12日
  • 支持向量机与支持向量回归(support vector machine and support vector regression)

    支持向量机与支持向量回归(support vector machine and support vector regression)支持向量机和支持向量回归是目前机器学习领域用得较多的方法,不管是人脸识别,字符识别,行为识别,姿态识别等,都可以看到它们的影子。在我的工作中,经常用到支持向量机和支持向量回归,然而,作为基本的理论,却没有认真地去梳理和总结,导致有些知识点没有彻底的弄明白。这篇博客主要就是想梳理一遍支持向量机和支持向量回归的基础理论知识,一个是笔记,另一个是交流学习,便于大家共勉。凸集、凸函数、凸优化凸集:如果集合…

    2022年5月29日

发表回复

您的邮箱地址不会被公开。 必填项已用 * 标注

关注全栈程序员社区公众号